Setting up and using Vitis

Installing and creating your first Vitis project

1429

Creating your first Vitis project

Tools Installation

Download and install the VITIS tool from the Xilinx website (be sure to choose the WebPack version). You will need to create and account and register with Xilinx in order to download WebPack, and the file is quite large, so you’ll want a good internet connection. After WebPack is downloaded and installed, you’ll need to obtain and install a license (the installer will guide you).

Create an empty VITIS Project

  1. Download the Vitis package from the Real Digital website, and save the .zip file for your board revision (Rev B or Rev D).

  2. Start the Vitis tool. You may see the Welcome dialog box – you can close this box.

Figure 1. Vitis Welcome Screen
Figure 1. Vitis Welcome Screen

To start a new project, click File -> Import…, and import the empty Vitis project you downloaded in Step 1 (choose the “Vitis project exported zip file" option). Navigate to the file you downloaded, and click Finish.

Figure 2. Import the empty project
Figure 2. Import the empty project
  1. After the file loads, select “blackboard.bist” in the explorer panel, and then select Project -> Build Project to extract and load the relevant data into your project workspace. The build may take a few moments – there’s a lot going on.
Figure 3. Build the hardware project
Figure 3. Build the hardware project
  1. Add a new application project to the workspace by clicking File -> New -> Application Project to bring up the New Application Wizard. Type a project name (maybe EE234P1, or something similar), and click Next.
Figure 4. Add a new application project
Figure 4. Add a new application project

The Platform selection box will appear – select the “blackboard_bist” file, and click Next. In the Domain box that appears, leave the defaults and click Next again to bring up the Templates box.

Figure 5. Select the correct hardware image
Figure 5. Select the correct hardware image
  1. In the Templates box, select “Empty Application”, and click Finish. You now have a properly configured project, and you can start adding your source code. All the resources described in the Real Digital resources page are available to your programs.
Figure 6. Add an empty application
Figure 6. Add an empty application

After creating the project, you will be in the Workspace view. From here, you can see all the files associated with the project, including the .xsa file and the BSP that were loaded earlier. Feel free to click around the workspace, and get a feel for what’s there. You can close the Application Project Settings window and the System Project Settings window if you would like – they are displayed by default in case you want to verify the settings.

Figure 7. Initial workspace view
Figure 7. Initial workspace view

To add new source code files to your project, right click on the “src” file icon located underneath your project name in the Explorer window, and click New -> File to bring up the New File box.

Figure 8. Add new source files
Figure 8. Add new source files

Enter a name for your source file, and be sure to use the “.S” suffix to tell the tools you are creating and assembly language source file (if you don’t use the .s suffix, it won’t work properly).

Figure 9. Be sure to use the “.S” suffix for assembly language sources
Figure 9. Be sure to use the “.S” suffix for assembly language sources

Now, you can add assembly code to the editor window.

Figure 10. Empty editor view
Figure 10. Empty editor view